4 ms·
It happened to me. I served my site over TLS and used HSTS. Hosting got expensive, so I rebuilt my site on Github Pages and hosted there. It was another year
by SquareWheel 7y ago
It happened to me. I served my site over TLS and used HSTS. Hosting got expensive, so I rebuilt my site on Github Pages and hosted there. It was another year and a half before they rolled out HTTPS for custom domains.
In that case, old visitors were rejected due to the policy.
I wish I had set a lower duration.
- sjwright 7y ago> old visitors were rejected due to the policy Also because their links and bookmarks would have all failed.
- shawnz 7y agoBut HSTS also blocks the workaround of "just Google it and find the page again"
- LinuxBender 7y agoYou can use the webmaster tools on Google to fix the indexing. It takes a few days, but worth the effort.
- MichaelApproved 7y agoThe issue is that the browser won't let you visit the insecure URL, regardless of how you get to it. It won't work because the HSTS setting the visitor got months ago told it not to.
- LinuxBender 7y agoThat is exactly what I am talking about. In the webmaster tools, you want to get google to remove all references to the non https versions. Ensure https is up on all URL's, then use their tools to re-index everything and remove all references to http:// http:// Are you saying you can't set up https on some of your URL's?
- shawnz 7y agoThe argument here is that enabling HSTS can be dangerous because if you enable it and then later become unable to serve HTTPS for some reason, you will have no way of turning it off. Even if you get your clients to manually edit their bookmarks to use HTTP again, their browsers will just rewrite the url to HTTPS anyway. There's no issue with switching FROM HTTP to HTTPS: that's easy, just redirect them. The issue is if you have to switch back.
- LinuxBender 7y agoI completely understand. The bookmark scenario is even easier than the google links. You simply set up https and the cached HSTS entries will work.
- shawnz 7y agoThe scenario is assuming you have a working HSTS setup but then become unable to serve HTTPS for some reason (e.g. cert expires and you can't acquire a new one, or the provider just drops support for SSL for some reason, or you are forced to change providers to one that doesn't support SSL) HSTS can't be enabled on plain HTTP so it's not possible to create the problematic scenario if you never had SSL enabled to begin with. The problem is switching from SSL to non-SSL, not the other way around.
- LinuxBender 7y agoEven if you can't renew a cert you paid for, in most cases you should be able to get a temp cert from Lets Encrypt and renew it every couple of months. I have free wildcard certs for many of my domains. HSTS just requires HTTPS. It doesn't pin the cert to a particular CA. That is what CAA records are for. Are you saying that you have applications that require HTTP port 80 only?
- shawnz 7y agoIt's true that letsencrypt makes this less likely to be an issue. But there is still the possibility that maybe your hosting provider drops support for HTTPS or you are forced to switch to a provider that doesn't support HTTPS. The parent gave one example of this with their GitHub Pages situation. Also: HSTS applies to all ports once applied, not just 80/443. That is another important thing to consider before turning it on.