3 ms·
Considering we actually have internet connected teapots now, I wonder if any mass market products have implemented this.
by FactolSarin 7y ago
Considering we actually have internet connected teapots now, I wonder if any mass market products have implemented this.
- trp1 7y agoNope, they recently removed that status code.
- furyofantares 7y agoFrom the spec. Teapots or any other devices are free to send it anyway
- grkvlt 7y agoOnly from clients supporting HTTP only. Note that RFC 2324 [0] defines the Hyper Text Coffee Pot Control Protocol or HTCPCP, which is an extension of HTTP and implementors of clients for this are free to return 418 if necessary. Also, RFC 7168 [1] which extends the protocol as HTCPCP-TEA now fully supports teapots, and is probably a better choice for modern clients. Also of interest is the SNMP MIB for remote management of 'Drip-Type Heated Beverage Hardware' which is defined in RFC 2325 [2] although this does not appear to have been updated with teapot, samovar, urn or other non-filter-coffee management data... Implementing tea making device remote management would probably be a good candidate for a GSoC project or even a startup if you can find a VC gullible enough to fund you! 0. https://tools.ietf.org/rfc/rfc2324.txt https://tools.ietf.org/rfc/rfc2324.txt 1. https://tools.ietf.org/rfc/rfc7168.txt https://tools.ietf.org/rfc/rfc7168.txt 2. https://tools.ietf.org/rfc/rfc2325.txt https://tools.ietf.org/rfc/rfc2325.txt
- ragebol 7y agoIIRC Ultimaker 3D printers do implement this
- mrguyorama 7y agoIt's always been my dream to build one. Now that we have things like Raspberry Pi zero W, I want to hack up my Kuerig and make that internet connected