4 ms·
The History of Email (2017)
- zackbloom 8y agoAuthor here, cool seeing this on HN. If you'd like another history, here's one on stock quotes which also forms a nice history of sending data far away: https://blog.cloudflare.com/history-of-stock-quotes/ https://blog.cloudflare.com/history-of-stock-quotes/
- anitil 8y agoI love reading these sorts of things. Working my way through the stock ticker article now It was a nice touch seeing some of the comments: > Expect lawsuit from Shiva Ayyadurai.
- ksec 8y agoI read the headline and I thought may be Cloudflare will be getting into Email Space too. And but doesn't seems to be the case. And none of Cloudflare's product or services has anything to do with email. So what was the purpose of the article from CloudFlare's perspective?
- gumby 8y ago> An early alternative to Unix called Tenex Ahem. Tenex ran on the PDP-10 (a mini mainframe for its time with a 36-bit word). Ritchie and Thompson were at that time still working for the Multics project (on a 36-bit architecture) and started writing Unix much later when they returned to Bell Labs (writing it on a smaller machine, PDP-7 and later PDP-11). > the Tenex team had just gotten access to the ARPANET Umm, the ARPANET IMPs were developed by BBN where Bobrow and Murphy were developing Tenex. ARPA was also interested in architecture and OS standardization at that time, in order to simplify research collaboration. > FTP originally didn’t include support for email. Around the time it was updated to use TCP (rather than the NCP protocol which ARPANET historically used) the MAIL command was added. Actually the mail command, as you even link to, was added in RFC 385 in 1972; the first TCP RFC was RFC 793 almost a decade later. (it's "the arpanet" by the way, being the network funded by ARPA, not some network named "arpanet" as, say, CSNET was). TECO did not become Emacs but Emacs was written in TECO from around 76 (IIRC it started last Gene Ciccarelli's TECO init file). RFC733 had nothing to do with how messages are stored on disk. Etc. I stopped after that.