4 ms·
If one is unable to change the port from its default, one doesn't have any business in developing web apps in any technology. Just sayin'.
by stilkov 16y ago
If one is unable to change the port from its default, one doesn't have any business in developing web apps in any technology. Just sayin'.
- jp 16y agoApache forks a child process with lower rights than root. App servers that run on port 80 do not without a native JNI lancher. The solution is native launcher, a router rule or iptables. I think the parent is talking about living in a chmod 777 world. Or maybe he is tired of crazy symlink hacks so that sftp becomes an option. Some appservers put class cache in WEB-INF by default, etc.
- rbrcurtis 16y agoSee my post below: a non-priv'd user can't start the java app server on a port sub-1024 unless you mess with the OS to allow it. I just double checked with my jetty install and I got a "java.net.SocketException: Permission denied".