3 ms·
I still have a bad bug with those versions. Anyone else? https://github.com/zfsonlinux/zfs/issues/8396 https://github.com/zfsonlinux/zfs/issues/8396 Basically,
by cracauer 8y ago
I still have a bad bug with those versions. Anyone else?
https://github.com/zfsonlinux/zfs/issues/8396 https://github.com/zfsonlinux/zfs/issues/8396
Basically, when serving NFS from a Linux-ZFS the client can read/write/seek fine, but on-demand paging sometimes fails (the same way it is supposed to fail when the file has been deleted server-side, but without any activity on the server).
So for example if you /usr is NFS emacs startup results in a bus error. The error rate increases with server uptime.
I tested ext2fs with the same linux kernel on the server and same clients - problem goes away. I use about the same ZFS version serving the same files from FreeBSD-current, error goes away.
I cannot be the only one seeing this?