3 ms·
Spam domain filters virtually killed self-hosted e-mail and what I presume was their major use case.
by rcdmd 8y ago
Spam domain filters virtually killed self-hosted e-mail and what I presume was their major use case.
- twothamendment 8y agoThere were times I thought that I'd have to give up, but it is much better than it used to be. I've been running my own email since 2002. There were some rough years, but I think we are past the days where you'd try to send to someone at {{big company} and get rejected. It's been quite a few years since I've thought too much about being rejected or fighting spam. It is a pain to setup DKIM, SPF, etc., but it all works now. I had to say "etc.", mostly because I don't remember all the hoops I jumped through. THe good news is that it has been so long I don't remember.
- m-p-3 8y agoI guess this period was a necessary evil to improve the email acosystem and make everyone a bit more concerned to setup their system correctly (even though it's non-trivial)..
- rhizome 8y agoI've run my own email out of my closet for close to 20 years and have no problem sending. I think DKIM/SPF probably help a lot, but I really can't say, as I've never been blocked (to my knowledge).
- jlgaddis 8y agoSame here. We're a long ways from the days when your machine would come with sendmail running and accepting mail for your FQDN OOTB, though... so it's a little more difficult but certainly not out of reach of anyone who is willing to put into the time and effort to learn how to do it right. (I plan on moving my mail to a new machine (well. new VMs) over the next few days and I expect to run into nearly no issues doing so. Then again, like rhizome, I've been doing this for ~20 years.)
- walrus01 8y agoAssuming you have a clueful and attentive upstream ISP and a static /29 or something, running your own mail out of your closet with proper rDNS, spf and dkim probably has better chance of delivery success than the same software setup, but on a dedicated server sharing a /24 of IP space with clueless and occasionally abuse-generating neighboring customers in the same netblock.
- rhizome 8y agoI have all that except for delegated reverse DNS, but that hasn't been a problem (again, to my knowledge!).
- jlgaddis 8y agoYou don't really need rDNS delegated to you (and I'm pretty sure that's not what walrus01 meant), just so long as you can set (or have your ISP set) the PTR RRs to match. Correctly set PTR RRs can (will) make a huge difference (lots of MTAs will reject if FCrDNS fails).
- walrus01 8y agoFunctionally from an smtp perspective it doesn't really matter if the rDNS is delegated to you, just that it's set correctly... ordinarily it's something you only have to set the PTR record for once, even if you need to manually ask your upstream to do it for the /32 that is your server, get them to set it to mail.whateverdomainname.net
- walrus01 8y agoIMHO if you do network engineering it's worth knowing the intricacies of modern SMTP setups. It is not that hard to build a wholly self hosted Postfix setup that has: Working reverse DNS SPF DKIM signing TLS1.2 transport to and from other smtpd, negotiated opportunistically. You can use a letsencrypt certificate. Is definitely not an open relay Requires TLS1.2 + SASL auth of your username and password to send outgoing mail (I use the same account credentials that are also my dovecot IMAPS account)