3 ms·
OK, I am trying to install haskell again using the instructions given in this guide. I removed my existing stack installation and my .stack directory, installe
by resoluteteeth 9y ago
OK, I am trying to install haskell again using the instructions given in this guide.
I removed my existing stack installation and my .stack directory, installed stack again, created a new stack project and then ran the recommended command in the guide to install ghc-mod and related tools: "stack build -j 8 --copy-compiler-tool ghc-mod hoogle weeder".
I get an error:
Error: While constructing the build plan, the
following exceptions were encountered:
In the dependencies for ghc-mod-5.8.0.0:
Cabal-2.0.1.1 from stack configuration does not
match >=1.18 && <1.25 (latest
matching version is 1.24.2.0)
...etc.
Can someone explain what's causing this?
- s4vi0r 9y agoCabal version too high. Did you have a pre existing cabal installation independent of stack or something?
- resoluteteeth 9y agoI don't think that I do. Is it possible that ghc-mod is broken on lts-10.5?
- lexi-lambda 9y agoIt isn’t broken in lts-10.5, it just isn’t in lts-10 at all. Go to https://www.stackage.org/lts-10.5 https://www.stackage.org/lts-10.5 and search for ghc-mod—it just isn’t currently available. Unfortunately, the reason for this is that ghc-mod still isn’t updated for GHC 8.2. It’s almost there—a package candidate has been uploaded that works alright—but it hasn’t made it into the LTS yet. There’s a way to build and install the package candidate in a way that will work with stack, which I have done on my personal machine, but honestly I decided it was just too much for this (already overly long) blog post.
- osense 9y agoYes, see https://github.com/DanielG/ghc-mod/issues/900 https://github.com/DanielG/ghc-mod/issues/900