3 ms·
Let's say I have an EBS volume of 500GB with 300GB of data. What happens if I mistakenly resize the EBS volume to 200GB? Do I get an error message or does part
by moofight 10y ago
Let's say I have an EBS volume of 500GB with 300GB of data. What happens if I mistakenly resize the EBS volume to 200GB? Do I get an error message or does part of my data get wiped out?
- falsedan 10y agoGood news: you won't lose any data from resizing your EBS down. Bad news: that's because you can't make your EBS smaller. > You can now increase volume size, adjust performance, or change the volume type while the volume is in use. Note the absence of 'increase OR decrease volume size'.
- moofight 10y agoYes, you are absolutely right. "EBS volumes can only be increased, not decreased".
- sidcool 10y agoAnd I think that's fair. Decreasing would be way too risky.
- falsedan 10y agoI fell there are better ways to protect your customers from data loss than forbidding a potentially-destructive action. I'm quite happy to lose data, or manage my data's physical location on disk, and do online decreases… but I can't!
- pjc50 10y agoI suspect it's the underlying systems that aren't good at handling online decreases. But the good news is, if you're happy to lose data, you can just delete the volume and create a smaller one. (Yes I know that's probably not what you meant, but it does highlight the question of what exactly is non-valuable data?)
- falsedan 10y agoI'm too lazy to attach new storage, sync data, and swap their mount points in place. > what exactly is non-valuable data? Caches, mirrors, backing volumes for redundant data stores or processing infrastructure that indicates to try again on another node on failure.
- deleted 10y ago[deleted]
- valdezmn 10y agoThere are third party solutions that support automatic/transparent rightsizing - both increase/decrease (FittedCloud).