9 ms·
I'm getting the following error "Cannot allocate memory - fork(2)" You can check out this video to learn more about hurl http://vimeo.com/6238577 http://vimeo.
by datums 16y ago
I'm getting the following error "Cannot allocate memory - fork(2)"
You can check out this video to learn more about hurl
http://vimeo.com/6238577 http://vimeo.com/6238577
- Emore 16y agoYep, me too. Seems like a useful service though.
- p0ppe 16y agoI can donfirm that. Only on the baconfile-example, tough. "Cannot allocate memory - fork(2)"
- rufo 16y agoI e-mailed Chris and Leah a friendly notice last Sunday about these errors and never heard anything back...
- codexon 16y agoI don't think you'll see it fixed any time soon. Using a fork per request is the easy way out. The problem as you've all seen, is that memory will be used up very very quickly. The solution is to rewrite the app to use an event loop like select or epoll, or to queue the requests in a message queue: doable, but worth the effort? I doubt it, since the website looks like a hobby rather than a commercial product.
- jackowayed 16y agoForking could fix the fork problem. That is, if someone forks hurl (http://github.com/defunkt/hurl http://github.com/defunkt/hurl) and rewrites it to use one of the fixes you referred to above, I'm sure they'd merge that in and deploy that. Doing it with Resque would make a lot of sense since hurl uses Redis already.
- codexon 16y agoWell sure, if someone does the work for them. I'm saying that's probably why Chris and Leah haven't fixed it already and probably for many days to come.
- jackowayed 16y agoYeah, I know. I just wanted to point out that we're not totally helpless here like we would be with closed-source software, and maybe encourage someone to fix it :)
- codexon 16y agoAnd I just wanted to point out that this isn't a simple 2-3 line fix so people won't get their hopes up trying to see if it's ready every few hours.
- jteo 16y agoSounds like a great usecase for Node.js. =)
- cmelbye 16y agoI assume that the problem is that because they're using Redis, the available memory was filled up with data from the database.