4 ms·
I pre-paid for 3 years of service but 1 year in they sent notification that the server farm would moved and I had 30 days to relocate my servers. Was pretty bus
by bayofpigs 10y ago
I pre-paid for 3 years of service but 1 year in they sent notification that the server farm would moved and I had 30 days to relocate my servers. Was pretty busy at the time so was an inconvenience to move everything, but I did.
Then I get the next months invoice and it's not using my pre-paid services but instead is billing for full CPU usage - no reserved instances.
After emailing support several times they say it's my own fault for not using the correct instance type, even though it's identical to the one I pre-paid for. It may well be my error but it was caused by them since I never asked for my servers to be moved. It's been an expensive and time-wasting experience -- will never use them again.
Am currently evaluating GKE (even more expensive) and DigitalOcean.