4 ms·
> That seems like a simple thing to accomplish; are you saying orgalog connects to all servers first before connecting to all servers again? orgalorg has two m
by seletskiy 10y ago
> That seems like a simple thing to accomplish; are you saying orgalog connects to all servers first before connecting to all servers again?
orgalorg has two modes: either it will fail and do nothing if even one server fails; or it will skip all errors and continue to do whatever it can with the rest. It allows you to run orgalorg on all set of nodes, but specify different keys and access only subset of servers.
> Please never do that [...] SSH is one of the few places where passwords are completely obsolete.
You simply making declarative statement there without any underlying arguments. Please never do that.
We have passwords as part of our computing infrastructures right now and there are lot of cases where you need to use passwords (e.g., legacy infrastructure). So, supporting valid way of vastly used authentication doesn't sound 'bad' for me.
>> * elevating privileges from user account to sudo (which is must have when you're logging in using your username, not root)
> Sure, that's easy..
I'm talking about rsync. Try to use non-root login whily syncing root-owned files. Orgalorg solves that trivially (just add `-x` flag and it's done).
Of course, I'm aware that key-based authentication is way superior than password based. I'm trying using SSH keys whenever possible and have distributed solution for syncing them across all cluster (https://github.com/reconquest/shadowd https://github.com/reconquest/shadowd). I do not find GUI-based solutions to be productive in work, so I prefer to use dead simple tools which are fail-safe because of simplicity.
Finally,
> but again if I was going to do this in production (i.e., automated), I'd probably not be doing it like this anyway.. I'd write a bash script, check status codes, timeouts, etc.
... and you will write orgalorg in bash.
- jamiesonbecker 10y ago>>>> * elevating privileges from user account to sudo (which is must have when you're logging in using your username, not root) > Sure, that's easy.. >> I'm talking about rsync. Try to use non-root login whily syncing root-owned files. Orgalorg solves that trivially (just add `-x` flag and it's done). Fair enough! FWIW, that's actually trivial with native rsync also: rsync --rsync-path="sudo rsync" (...) That calls rsync as 'sudo rsync' on the remote system.