7 ms·
Replying to myself as a follow up: Make sure the S3 bucket is set to Static Website Hosting mode, and make sure your Index and Error documents are set appropri
by owenconti 10y ago
Replying to myself as a follow up:
Make sure the S3 bucket is set to Static Website Hosting mode, and make sure your Index and Error documents are set appropriately. Then make sure your CloudFront distribution is pointed at the Website's endpoint and NOT the normal S3 endpoint.
- dwightgunning 10y agoThat's exactly my configuration and works like a charm.
- owenconti 10y agoI initially had issues because I was pointing CloudFront at the normal S3 endpoint. Once that was solved, everything started working smoothly.