3 ms·
I struggled with getting HTTP/2 working with ALPN on Ubuntu 14.04 back in February. After building nginx from source [1] I ended up switching to Docker base ima
by smithclay 10y ago
I struggled with getting HTTP/2 working with ALPN on Ubuntu 14.04 back in February. After building nginx from source [1] I ended up switching to Docker base images that support OpenSSL 1.0.2 [2].
1: https://www.clay.fail/posts/ubuntu-http2-in-mere-hours https://www.clay.fail/posts/ubuntu-http2-in-mere-hours
2: https://www.clay.fail/posts/hip-http2-using-docker/ https://www.clay.fail/posts/hip-http2-using-docker/
- leesalminen 10y agoI actually found your blog post [1] on Google earlier this morning after seeing this thread. It was hugely helpful. Thank you very much for writing it. Was there a bug or technical limitation that made you switch to a Docker image or just preferences/ease of updating?
- smithclay 10y agoThe main reason I switched Docker is there's an nginx image (on alpine) that supports ALPN. No compiling from source required, which simplified things (in my mind, at least).
- leesalminen 10y agoGotcha. As a heads up, there's a confirmed bug with HTTP/2 implementation on nginx 1.9.15 and 1.10.0. It seems to affect Safari and iOS (native and browser) markedly. For me, the first HTTP/2 POST request to a server running the affected version of nginx would never leave the browser and Safari left a less than descriptive "Failed to load resource: Could not connect to the server." console message. I'm having luck with 1.9.12 + OpenSSL 1.0.2h https://trac.nginx.org/nginx/ticket/979 https://trac.nginx.org/nginx/ticket/979 https://trac.nginx.org/nginx/ticket/959 https://trac.nginx.org/nginx/ticket/959