3 ms·
I thought NTFS and ZFS are the enterprise filesystems of choice? We merely tolerate others. That has been my experience over the last 15 years or so.
by buffoon 11y ago
I thought NTFS and ZFS are the enterprise filesystems of choice? We merely tolerate others. That has been my experience over the last 15 years or so.
- mhurron 11y agoNTFS because you have to, ZFS has a little restriction on it that makes it difficult to be 'of choice' and EXT4 needs to go away for huge volumes. Linux with a huge volume? Use XFS.
- buffoon 11y agoOr use FreeBSD with ZFS or buy a NAS appliance.
- bnolsen 11y agoi recall XFS had some serious corruption issues if a failure happens when not on a UPS (or the UPS fails catastastrophically). Has this been dealt with ?
- mhurron 11y agoFrom personal experience I can say that I haven't seen it recently. RHEL 7 went to XFS as their default filesystem so hopefully they've looked into it.
- dwdz 11y agoYes, it had but that bug was fixed like 10 years ago. Stop spreading FUD.
- buffoon 11y agoPossibly fixed. I've had one incident of an XFS filesystem refuse to mount after it replayed the journal after a power outage. xfs_repair worked but I shouldn't have to piss around in single user mode in 2015. Kit was a HP DL380p, SmartArray 420i SAS array, CentOS 7 about 3 months ago. Outage caused by a large UPS explosion that took out 100 machines. No NTFS or ext3/4 trouble at all.